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Introduction
This document is intended to provide help in installing and using
Lifely Agrumino Lemon. In addition, some example sketches will
be illustrated, which can be found in the "Examples in Arduino
IDE" category, subject to installation of the Lifely Agrumino
Lemon library (we recommend always using the latest
version).

1

IMPORTANT! Correct battery insertion
When using the battery, pay attention to its insertion: insert the
battery in the correct way, that is, with the silkscreen facing up
(see figure below). Incorrect insertion of the battery by reversing
the polarities would cause a short circuit.

Screen printing
facing upward
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SWITCH
OFF!

If you use rechargeable batteries, the charging circuit should
always be set to ON (see Figure 1). 
If, however, you use non-rechargeable batteries, the charging
circuit must, of necessity, be set to OFF (see Figure 2). Failure to
set it to OFF would cause the device to short-circuit.

IMPORTANT! Activation/Deactivation of the charging
circuit.

Figure 1
RECHARGEABLE

BATTERY

SWITCH
ON!

Figure 2
NON-RECHARGEABLE

BATTERY
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Hardware

This section highlights the main components of the Lifely
Agrumino Lemon device.

2.1 Lifely Agrumino Lemon rev4 (front-board) 

Led

Temperature sensor

User Custom Button

CHIP ESP8266

Battery ON-OFF (with
jumper and without

jumper)

Soil moisture sensor

Light sensor

Reset Button

(1)Battery recharge ON-OFF
(2)Power to I2C ON-OFF

Micro USB connector
recharge/programming

Battery holder

2
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2.2 Lifely Agrumino Lemon rev4 (back-board)

The I2C connector and GPIO connector are compatible with Grove
Systems.
Grove I2C e Grove Digital sono supportati out-of-the-box mentre
Grove Analog può essere utilizzato con un esterno Grove-I2C-
ADC.

Water sensor
level connector

(generic IO)

Pump connector (*)

I2C connector
(Grove compatible)

External battery
connector 

GPIO Connector
(Grove

compatible) (*)

http://wiki.seeed.cc/Grove-I2C_ADC/
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2.3 Lifely Agrumino Lemon rev5

The rev5 version of the Lifely Agrumino Lemon device is perfectly
the same as the rev4 version, the only difference being that there
is no jumper. The latter is replaced by a toggle located in the
back-board, with an ON-OFF switch (see figure below).
We specify that the color is not indicative of the model version. 

Back-board

Board Version

Switch Power
ON-OFF
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1 I2C connector (Grove
compatible)

External battery
connector (*)

GPIO Connector (Grove
compatible) (*)

Pump connector
max. 3.3 V (*)

Water sensor level
connector (generic IO)

2

3

4

5

Pinout and Connector

1

23

4

5

In this section we are going to analyze, in more detail, the
connectors present in the back-board of Lifely Agrumino Lemon
(in the image below we have used a rev4 but it is identical to the
rev5). The connectors are as follows:

3
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3.1 I2C connector (Grove compatible)

SCL

SDA
VOUT (3.3V)

GND

3.2 External battery connector (*)

Connection of non-rechargeable battery is possible after
disabling charging circuit (see page 4).

BATT -
BATT + (max 6.0V)
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3.3 Pump connector max. 3.3 V (*)

Software-activated irrigation pump connector.

MAX VOUT 3.3 V 

GND

3.4 Water sensor level connector (generic IO)

GPIO_LIV_1 

GND
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3.5 GPIO Connector (Grove compatible) (*)

GPIO_2 

GPIO_1 

VOUT (3.3V) 

GND 
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Installations and configurations
4.1 CP210x USB Driver Installation

Modern Windows installations already have USB drivers for its
operation. On other platforms, such as Mac OS/Linux and
Android, if the serial device is not automatically recognized, you
can download the latest version of the official driver from this
link: CP2102 Driver.

4.2 Install Lifely Agrumino Lemon on Arduino IDE -
procedure valid for Arduino IDE versions lower than
version 2.0

If you have the Arduino IDE version 1.8.19 please follow this
procedure.
The Lifely Agrumino Lemon Core is an ESP8266 WiFi. The official
programming IDE is Arduino, thanks to the ESP8266 Core for
Arduino project. In addition, it is also possible to use other IDEs,
such as VSCode, using the Platformio extension. Lifely Agrumino
Lemon is officially part of Arduino's ESP8266 Core. Arduino allows
installation of packages using the Board Manager. The package is
available for Windows, Mac OS, and Linux (32- and 64-bit). Follow
the following steps to proceed with the installation:

4

1. Install the latest version of Arduino IDE lower than 2.0
available in the official Arduino website at the following link:
https://www.arduino.cc/en/software

2. Next, open Arduino Ide and click on 
File → Preferences and in the URLs text box enter the following
url:
http://arduino.esp8266.com/stable/package_esp8266com_index.json

https://www.silabs.com/documents/public/software/CP210x_Universal_Windows_Driver.zip
https://github.com/esp8266/Arduino
https://www.arduino.cc/en/software
http://arduino.esp8266.com/stable/package_esp8266com_index.json


3. If there are additional configuration URLs of other tabs, simply
separate them with a comma. Open Tab Manager (Tools → Tab
→ Tab Manager and type Esp8266). At this point a screen like
the one in the image below will be visible.
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Having reached this point, we install version 3.0.0 or later.

4. Select "Lifely Agrumino Lemon" via the menu Tools → Tab →
ESP8266 Boards and select Lifely Agrumino Lemon v4
(selection also valid for rev5).
If you have done everything correctly, at the bottom of the
Arduino IDE you should see Lifely Agrumino Lemon v4, as in
the spot highlighted in the following image.
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4.3 Installation of Lifely Agrumino Lemon libraries on
Arduino IDE
To use Lifely Agrumino Lemon, you must install the Official
Library. You must do this directly from the library manager in
Arduino IDE.
To do this go to Tools → Library Management and then type in
"Lifely."

Installing the library will install some sample sketches, which are
useful to start using Lifely Agrumino Lemon without having to
write a single line of code.

A screen like the one in the figure will appear. Now you need to
install the latest library release, for example as in this case 1.4.4,
by simply pressing the Install button. 
Always install the latest release of the library.
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Lifely Agrumino Lemon
Program
The Lifely Agrumino Lemon board can be easily programmed: you
simply select an example sketch found in the examples folder and
then upload it by pressing the Upload button on the Arduino
IDE. In addition, you can freely write code to create your own
sketches.
From the Arduino IDE menu (Tools → Board) verify that you have
selected the correct "Lifely Agrumino Lemon v4" board.

Using the Lifely library with
Arduino IDE
This section will briefly present some Example Sketches. Note
that they are divided into the following folders: QuickStart,
Cloud, Advances examples, OTA and Diagnostics. 
(File → Examples → Lifely Agrumino Lemon).

6.1 Examples in "QuickStart"
These Sketches display basic Agrumino data, such as reading
sensor data, saving data to flash memory, and controlling the
wifi connection.

AgruminoSample
Simple sketch to read every 30 seconds (configurable
parameter) all values from Lifely Agrumino Lemon and
display them in the serial monitor of Arduino IDE.

5

6



AgruminoBringUp

Sketch to test Lifely Agrumino Lemon and its FLASH
memory of the ESP8266 module. Specifically, it is possible
to read all sensor values and print them in the serial
monitor, as well as clean, read, write, and commit to the
memory to verify its integrity.
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WifiClient (ESP8266 example)

Sample sketch to connect Lifely Agrumino Lemon to a WiFi
connection. You need to write STASSID and STAPSK with a
personal WiFi SSID and password.

6.2 Examples in "Cloud"

With these Sketches it is possible to send sensor data from the
Agrumino board to various Cloud platforms. All Sketches use
"deep sleep," a special power-saving mode.

AgruminoDweet

Sketch that reads all values from Lifely Agrumino Lemon
every hour and transmits them to the Dweet.io service
every 4 hours. It integrates FLASH management to collect
all data before transmitting it.

AgruminoThingSpeakHttpPost

Like the AgruminoDweet Sketch, but in this case the data is
sent to the cloud via Post Http.

AgruminoThingSpeakJsonPost

In this case all data are sent with one Json file.
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AgruminoThingSpeakVeryEasy

Similar to the sketch in which data is sent to the server
with a direct connection.

AgruminoThingCloudWithPump

Sketch that sends all sensor data from the Lifely Agrumino
Lemon at the Thinger.io platform. Through the Thinger.io
Dashboard and this firmware, it will be possible to enable
or disable irrigation directly from the pump connector.

6.3 Advanced examples

Example sketch with Lifely Agrumino Lemon, using other sensors,
actuators, third-party boards such as OLED display, water pump, etc.

AgruminoOledSample

Data visualization by connecting an oled display.

6.4 OTA flashing to update firmware examples

Sketches that send sensor data to the cloud and at the same time
use Over The Air (OTA) updates.

AgruminoDweetWebOTA

This sketch is the same as AgruminoDweet, but integrates,
in addition, firmware updating via OTA using a web page.
Users can choose an update file from PC and upload it to
the board using the Lifely Agrumino Lemon address.
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AgruminoDweetHttpOTA

This sketch is the same as AgruminoDweet, but it integrates
firmware updating via OTA using a remote HTTP server.
Whenever a binary file (.bin) is uploaded to the server, the
board automatically downloads it and the device is updated
totally autonomously.

6.5 Diagnostics

AgruminoLemonTesting

This sketch can be used to verify the operation of all
connectors and integrated sensors. Within the sketch folder
is an illustrative image of its use (fritzing diagram). The
path to the images is as follows:

\Arduino\libraries\Lifely_Agrumino_Lemon\examples\Diagnostic
s\AgruminoLemonTesting
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FAQ and common errors
1. Error: Agrumino not connected
Check from the Arduino IDE menu (Tools → Port) that the
selected port is the one for your Lifely Agrumino Lemon. In case
of other usb peripherals connected, check the one corresponding
to Agrumino Lemon. On Windows systems, device management
can be used. Verify that the cable used is a data cable.

2. Error: espncom sync error
Press the Lifely Agrumino Lemon reset switch (screen-printed
"S2" in the upper left) and try again.
If the error recurs disconnect Lifely Agrumino Lemon from the
Usb cable, remove and re-insert jumper P1. Then try the
procedure again. 
In case of persistent errors not found in FAQ write an email to
support@lifely.cc, having as subject "Support request via link on
Dev Guide".

7

3. Problem: Windows 11 can't find the Lifely device
Absence of the CP210X driver in the operating system. Perform as
indicated in the section "Installations and configurations."

https://support.microsoft.com/it-it/windows/aprire-gestione-dispositivi-a7f2db46-faaf-24f0-8b7b-9e4a6032fc8c
mailto:%20support@lifely.cc


Tutorial with Arduino IDE
(classic version)
Up to Arduino IDE version 1.8.19. 
Before proceeding, you need to install Arduino IDE from this
link: https://www.arduino.cc/en/software

After installing Arduino Ide, connect Lifely Agrumino Lemon to
your PC/MAC with micro usb cable.
Now open the Arduino IDE, go to File and click on Preferences.

8
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Now in the text box "Additional tab management URL" copy
and paste this link and then click OK:

http://arduino.esp8266.com/stable/package_esp8266com_index.json

https://www.arduino.cc/en/software
http://arduino.esp8266.com/stable/package_esp8266com_index.json
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Now go to Tools → Tab → Click on Tab Manager.

In the text box type "ESP8266", you will immediately find
ESP8266 and click Install.
Important! Install only versions 3.0.0 or later.
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After completing the installation click Close.

Now go to Tools → Tab → Esp8266 Boards (3.0.0) and with
one click select Lifely Agrumino Lemon v4.
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If you made the choice correctly, you should see the words
"Lifely Agrumino Lemon v4" in the lower right corner, as
highlighted in the image below.

Now you need to install the official library, so go to:
Tools → Library Manager and type in "Lifely" (see image
below).

Now you need to click on Install (always install the latest
release). By installing the library, all the example sketches will
also be installed.
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Now connect the Agrumino to the Pc and go to Tools → Port and
choose the correct port (COM19) related to your Lifely Agrumino
Lemon. To figure out which port is used by your device see
Section 7 FAQ 1.

Now select the base sketch, to find it you need to go to: File →
Examples → Lifely Agrumino Lemon → QuickStart →
AgruminoSample and then upload the sketch by pressing the
button highlighted in the figure:
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Now that you have loaded the sketch on Agrumino, to view the

data acquired by the sensors click on this button       to open the

serial monitor (arrow 1) next, change the "baud rate" to 115200

(arrow 2) and now you can finally view the data acquired by your

Agrumino Lemon (arrow 3).

From now on, you can better manage your device.
Also try the other sketches in the examples folder of

Lifely Agrumino Lemon.
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Tutorial with Arduino IDE 2.09
Coming soon!



You can contact us at the following email
address for more information:

support@lifely.cc

rev 1.2_ITA
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